Installing TightVNC - It will not connect!

January 6, 2015 5k views

Hi, i'm really needing to Install TightVNC on my droplet 'Steam'. Using Ubuntu

I've followed the tutorials and others of site but still cannot get it working only the error from TightVNC when trying to connect "The target machine actively refused it".

I tried this exactly.

I've wiped the droplet and tried installing again but it just doesn't seem to work!

I hope to get this sorted asap.


2 Answers

After starting up vnc on your droplet, is your server listening to the expected port/display number? Try running the following command on your droplet after you start up vnc

vncserver -list

If you use Putty to establish the SSH tunnel from your PC, make sure the tunnel uses the corresponding port. For example, if the port/display# from the output above is ':01', setup your SSH tunnel in Putty to use a source port of 5901 and a destination of localhost:5901 , then use localhost:5901 as the vncserver name you give to your vnc viewer.

The example conceptually looks like

vncviewer ==> Putty ssh tunnel at 5901 to remote 5901 ==> remote vnc port at 5901 ==> vncserver

You should get a vnc password prompt once you initiate your viewer

I have exactly same problem as zyteog. vncserver -list doesn't seem to be valid argument.
I get below error: Unrecognized option: -list

Have another answer? Share your knowledge.