Question

Intermittent white screen with “Failed to load resource: net::err_connection_reset” in console log

Posted February 16, 2020 271 views
CentOSApachePHPWordPress

I have a WordPress website which is on it’s own server with the only other site on there being the DEV version of the site.

When browsing around the website (back and front end) I sometimes get a blank white screen with no error on the screen and no fatal errors in the log, only a “Failed to load resource: net::errconnectionreset” message in the console log.

I refresh the screen and the website acts as if there is nothing wrong.

I’ve tested on different networks and PCs but still get the issue. I’m using Sucuri but have chatted with them and they provided me with the logs and I can see my IP isn’t being blocked at any point.

I browse around the dev site which isn’t going through Sucuri firewall or a caching plugin and I don’t get the issue.

I’ve done a lot of Googling but some people saying its a website issue and some people saying its a local browser/firewall issue so I have no idea what it could be.

Does anyone have any ideas or suggestions on how to fix or even to debug the issue further?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello,

What I could suggest is to check your server logs and see if there is more information in there. Also try to enable the Wordpress debug mode and see if you get any other errors besides the Failed to load resources one.

You could take a look at this answer here on how to troubleshoot common Apache problems as well:

https://www.digitalocean.com/community/questions/how-to-troubleshoot-common-apache-issues-on-linux-server

Feel free to share the output of the logs here so that I could try to advise you further.

Regards,
Bobby

  • Thanks for the reply!

    In the server logs we only have these 3 below lines a few times but none of them match the timestamps of when we logged the issue. Could any of these be related? We have enabled the WordPress debugging but no fatal errors or warnings, only some notices.

    AH01630: client denied by server configuration: /REMOVED/public_html/403.shtml

    AH01630: client denied by server configuration: /REMOVED/public_html/

    AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use 'LogLevel debug’ to get a backtrace.

    Thanks in advance!

    • Hi there @bcross1994,

      If you are using PHP FPM, for example, you could take a look at the PHP FPM logs as well. I believe that the default location on CentOS is:

      /var/log/fpm-php.www.log
      

      If this is not the case, you could check your PHP FPM config and find the error log location there.

      As the error is intermittent you might be hitting either PHP FPM or Apache thread limits.

      Regards,
      Bobby

Submit an Answer