Hi. i edited htacess from wordpress dashboard and now it shows up internal error 500. i munable to go to my site, admin area, dashboard. as i guess it needs to be recovered, updated or undo or disable htacess (i don t know how to say) how can i do that, how can i fix this issue. i edited htacess by adding some code snippet from random video tutorial. i didn’t know possible results. (despite that i was wondering about something will go wrong)

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi there @levanmirvelashvili,

I would recommend either trying to delete the code snippet which you added and then save the file again and see if this works.

If the site is still returning a 500 error I would recommend just adding default .htaccess file with the following content:

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Make sure to take a backup of your current .htaccess file just in case anything goes wrong.

Besides that to see the exact problem which is causing the error, you can take a look at your Apache error log:

  • sudo tail -f /var/log/apache2/error.log

Let me know how it goes!
Regards,
Bobby

  • Hello first of all thanks for helping. that’s what i tried as soon as i bumped into this problem. but i can’t acces to dashboard or any page.
    i also tried from ftp filezilla. watched some tutorials about it.
    but i can’t find htaccess file in ftp. which i connected by ip adress root username and password.

    • Hi there @levanmirvelashvili,

      I would recommend using [SSH to connect to your Droplet](digitalocean.com/docs/droplets/how-to/connect-with-ssh/) and checking the error log for some more information.

      If the .htaccess file does not exist, you can create a new one and add the default content.

      Feel free to share the exact error that you are still getting here and the errors from the Apache error logs so that I could try to advise you further.

      Regards,
      Bobby

      • as i know i can connect without ssh, via ftp only right?
        when i m trying to connect via ftp i get connection failed message (winscp) how can i get why this error happens? i think it has nothing to do with protocol
        sftp or ftp right? (connect via ssh key is better but i can go with ftp too) but i don’t know why can’t connect to server. maybe there is problem in server?
        in console i get : end kernel panic not syncing attempted to kill init exit code =0X00000100
        and CPU usage is on 100%

        • Hi there @levanmirvelashvili,

          Indeed it sounds like something is not right with the server, have you tried rebooting and also do you have a backup or a snapshot of your Droplet which you could restore in case that the server is not booting at all?

          Regards,
          Bobby

@bobbyiliev i didn t have backup. can in back up now

Submit an Answer