Question

Ip Address instead of Domain Name

Posted May 24, 2016 7k views
NginxDNSLEMP

Hi There

Wordpress Installation based on Nginx.

I recently set up my Dns records and my site has a strange behavior.

If you try to connect to the domain name: ggtest.it
you go to the site but the browser shows the Ip Address instead of the domain name!

Here is my Nginx configuration

server {
listen 80 defaultserver;
listen [::]:80 default
server ipv6only=on;

    root /var/www/html;
    index index.php index.html index.htm;

    # Make site accessible from http://localhost/
    server_name ggtest.it www.ggtest.it;

    # Per aumentare la capacità di caricamento in wordpress
    client_max_body_size 32M;

    location = /xmlrpc.php {
    deny all;
             }

    location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
            # try_files $uri $uri/ =404;
            try_files $uri $uri/ /index.php?q=$uri&$args;
            # Uncomment to enable naxsi on this location
            # include /etc/nginx/naxsi.rules
    }

Have you any idea about what this can be due to?

Have you any suggestion to sort the problem?

Thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

This will occur if your WordPress settings have the IP address set as the domain name and base_url. You can find this inside the settings in wp-admin.

What happens is that WordPress has a set URL in it’s settings. When a request comes in that hits WordPress but does not match the configured base_url it redirects to the configured URL, in this case, the IP address.

Submit an Answer