Question

IP address still showing in address bar after domain resolves

  • Posted December 17, 2016
  • DNS

I have a domain, ‘example.com’, registered with Bluehost. I also have a droplet with DigitalOcean. Now, I’ve re-pointed the nameservers to use CloudFlare. Great.

After adding the DNS entries, I go to a browser and type in ‘example.com’ … it properly resolves to the correct IP address of the correct Droplet.

But: in the browser bar, upon resolution and display of the Droplet’s server page, the address bar then stops displaying the domain - and, instead, exposes the IP address.

I have tried a 1000 different configurations - including trying same for a subdomain.

However, nothing seems to correct the problem, preserve the domain/subdomain in the address bar, and not display the IP address.

Here’s what I get: Domain: www.example.com/index.html --> xxx.xxx.xxx.xxx/index.html Subdomain: subdomain.example.com/index.html --> xxx.xxx.xxx.xxx/index.html

What am I doing wrong??

Subscribe
Share

Goto Wordpress Admin Panel Settings >> General > > Change WordPress Address (URL) & Site Address (URL)


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Is this a static site or are you using a CMS like WordPress? We see this issue quite a bit when WordPress sites are created and the setup is done before a domain is assigned. WordPress will set the SiteURL setting to the IP address and by default will direct any requests it receives to use it’s configured URL/hostname. If this is the case you can change this setting in the General settings section of /wp-admin

If you’re running a static site or something else, can you share your virtualhost configuration and if one exists, the content of any .htaccess file located in your web root directory?

This is not related to DNS. What you are describing is a redirect done at the web server or application level (A DNS issue would prevent the name being resolved but has no ability to force a particular URL to show up in your address bar)

I have the same issue with Magento 2.x Anybody has an idea how to go about this in Magento? I tried editing “/etc/apache2/apache2.conf” and replaced the IP address with the domain but still not working. Anybody knows what do?

Yup. I got the same problem, and problem was wordpress configuration. Thanks for help. GL

I had the same issue with my Wordpress site. I logged in and went to settings and it was set to http://ip address. I changed it to http://www.example.com and saved the settings. When going back to the website, it displayed the domain name instead of the ip address.