Question

IP adress instead of domain name in Ghost

Posted February 7, 2018 3.8k views
Ghost Ubuntu 16.04

Hello! I have a little problem with my installation of Ghost. I installed it and set target from my domain to it. I also setted it up to be only available at the domain I chose. Everything is working, but all links at the blog leads not to the domain, but to the IP of my Droplet.

Do I need to change anything in a config? And where do I need to change it?

Thanks,
Lukáš Pánek

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

2 answers

For Ghost to properly generate links with the domain name of your blog, you need to edit a setting in its configuration file. The file’s name is config.production.json If you are using the DigitalOcean Ghost One-Click application, it is located at /var/www/ghost/config.production.json

Find the section of the file containing the IP address:

  "url": "http://111.11.11.111",

and edit it to contain your domain name:

"url": "http://example.com",

You can also do this using the Ghost CLI tool from inside the Ghost directory:

  • cd /var/www/ghost/
  • ghost config url http://example.com

Finally, you will need to restart Ghost for the change to take effect:

  • ghost restart

Hello, it says permission denied when I tried running this:
/var/www/ghost/config.production.json

  • You supposed to log in as ghost-mgr. Simply type this in Ghost CLI.
    sudo -i -u ghost-mgr

    It’s displayed in the welcome screen while logging to CLI, but you used already it happens to display last used commands instead of this welcome screen. It took me a while to get it ;)

Submit an Answer