Is Digital Ocean still compatible with Virtualmin?

October 7, 2018 1.2k views
MySQL Ubuntu 16.04

I tried to use Virtualmin to set up a new Ubuntu 16.04 droplet. It was a nightmare. I got the following errors after the installation of Virtualmin:

  • first php files were not recognized as such and downloaded instead. I managed to find a solution for that on the internet where I had to delete the text "phpadminvalue engine Off" in a mydomain.com.conf file.
  • next I found that I couldn't set the password in Virtualmin. I had to directly to the Mysql command line.
  • finally I found serious problems uploading sql files that I had exported with phpmyadmin. Somehow escaped single quotes in the file crashed the upload. And when I tried to fix these I got a 500 error with in the log file "too many redirects" errors.

It looks like things are getting worse over time:

  • have a DO Ubuntu 14.04 installation with PHP 5 that doesn't give problems
  • I have a two and a half year old DO Ubuntu 16.04 installation with PHP 7.0 installation that only gives problems when I try to import large databases
  • when I now try to set up something with DO Ubuntu 16.04 I start with the downloading php files.
1 comment
  • Heya,

    I've just set'up a virtualmin instance on Ubuntu 16.04 x64 and managed to get a working wordpress site on it. This is the guide i've used. I did skip the dist upgrade part from the guide tho.

    Droplet info: 2GB ram 2 CPU.

    The line i ignored:

    sudo apt-get dist-upgrade -y
    

    I stopped following the guide after this line:

    sudo /usr/share/webmin/changepass.pl /etc/webmin root yourpassword
    

    There seem to be options to select the PHP version you want to use on a certain website if there are multiple php versions installed on the system.

    Regards,
    Alex

    by Joshua Tan
    Virtualmin is a web-based interface that simplifies the management of multiple virtual hosts through a single interface, similar to cPanel or Plesk. With Virtualmin, you can manage user...
2 Answers

I maintain the Virtualmin installer.

I haven't tested on a DO droplet in a while but we've had a few reports of new issues on Ubuntu...they don't seem to keep their packages as stable as RHEL/CentOS (config files change, versions change, etc. in ways that we have to alter the installer to work with). So, I would guess it is changes in Ubuntu rather than changes at DO, though maybe they've altered their master image for Ubuntu 16.04 in ways that cause trouble. We have seen VPS/VM hosts that provide customized packages or configurations that are weird and non-standard in various ways...historically DO hasn't been one of them, I don't think.

I'm currently doing some more work on 18.04 support (which has been a PITA due to the new netplan network configuration system, which required a bunch of new code in Webmin), but will try to spend some time with 16.04, as well. I've been testing on DO droplets more often lately since it seems to be a common installation target for our users.

The issues you're seeing are pretty mild, however...they're configuration not stability or functionality issues. So, do keep that in perspective...I know it can seem like things are spinning out of control when a bunch of things that used to work start behaving weirdly. It's just config files changing in ways we didn't anticipate when we built the installer for 16.04, not a "bug" per se. CentOS sees a lot less of these problems, because CentOS excludes incompatible changes between minor versions.

Sounds like you've sorted the PHP issue. You can also solve it by simply disabling mod_php entirely (this is what I do on all of my servers, but when I talked about removing it from the default installation a while back, I got a lot of pushback...but, I really think no one should be using mod_php anymore, and Virtualmin 7 will not install/configure it by default).

The MySQL password issue we've seen, off and on, for ages, and I still don't know how to fix it. When it happens, you can usually just back up and do it again. i.e. when you get the error about the password not being set or whatever, just click the button for the previous step or whatever. If it's the problem I think it is, Webmin will either let you set the password again or will detect that the password was actually set and things will Just Work. You can also force a password reset after installation in the Webmin MySQL module.

The import issue is new to me. Are you importing within the Webmin MySQL module (clicking "Manage Databases" in Virtualmin uses the Webmin MySQL module)? If so, have you opened a ticket about it (in the github tracker for either Webmin or Virtualmin GPL, though I think this would be happening in Webmin)? We'd need to see an example database dump that triggers the problem. I'm inclined to think PHPMyAdmin is doing something weird, since our export and import are handled using MySQL pretty close to directly, without much munging of the files, but we shouldn't bail without some kind of reasonable error even if something is wrong with the dump.

Cheers,
Joe

More bad news. This is becoming really a trouble.

I decided to continue with the old installation that contained PHP 7.0.

I needed a PHP 7.1 so I added it with "apt-get install -y php7.1 " followed by some modules. That worked ok after some struggle.

However, the page that recommended that also told me to add PPA (add-apt-repository -y ppa:ondrej/php) and that proved a first class disaster. When I ran the next update session it installed PHP 7.2 and switched my site to that (what it can't handle). It was a struggle to get back to 7.1 and when I finally succeeded my php files started downloading again. And this time removing "phpadminvalue engine Off" didn't help...

Have another answer? Share your knowledge.