Question

Is there a max_execution_time limit on a droplet?

Posted March 7, 2016 6.7k views
PHPDigitalOcean

I have a 5$ droplet and tried various ways of setting maxexecutiontime (php) to 300, but it always defaults to 30. So, my question is if there is a limit which is on top of a droplet?

Thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
3 answers

No, there is not. This setting would be changed in one of the following files depending on how you’re using PHP:

On the command line:

/etc/php5/cli/php.ini

Running via mod_php in Apache

/etc/php5/apache2/php.ini

For changes to this file to take affect you should restart apache with service apache2 restart after making changes.

Running with php5-fpm (usually nginx)

/etc/php5/fpm/php.ini

For changes to this file to take afect you should restart the fpm service with service php5-fpm restart after making changes.

/etc/php/7.2/apache2/php.ini

then clt+w and paste maxexecotion time and change 30 to 300 then to save clt+x then y then enter

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of max_execution_time you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites).

You also need to restart your web server in order the changes to take effect. Additionally a restart of the php-fpm restart is also needed.

Hope that this helps!
Regards,
Alex