is there any sort of inbound request limit?

I have tried with 3 different droplets with different linux distros installed.

it seems like there’s some sort of “10req/s limit” set on its public network.

when I run apachebench or any other tools to stress test the new server, I get exactly 9~10 req/s.

it doesn’t seem to be a cpu-bound or ram-bound issue since during the test, cpu utilization is kept below 1.0%

If i run the stress test in localhost, i get something like 8000req/s. hitting maximum cpu of 85~95%

here’s a droplet with its current vanilla nginx settings. can you guys take a look?

Is there some sort of anti-ddos limit or per-ip request limit implemented? i’ve looked if there’s any iptables rule or firewall(ufw) rule set on the droplet, but there weren’t any.

i’ve tested the nginx server on port 80, 8080,21, 3389 and other ports, and same results. apache gave me same results. testing from a different remote location gave me that 10req/s limit. seems to be a server-network side issue.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @ryanpq:

There is not any type of rate limiting on the network for your droplet that would cause this. Are you running behind CloudFlare or another reverse proxy service by chance? When running these benchmarks where are the requests being generated from? If possible a traceroute between that location and your droplet would be helpful in seeing if there is a network issue causing these problems for you.

View the original comment