Ispconfig3 emails not working but mail server is working. i can ping it. Google also says mail takes forever when adding emails. I can traceroute.. see errors below.

July 16, 2014 3.2k views

I am running Ubuntu and I am trying to setup my mail server using ISPConfig 3. Here is the error I am getting:

Mail Queue (Server :
Data from: 2014-07-16 12:40
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
0D0FA25451 627 Wed Jul 16 03:21:02
(connect to[]:10024: Connection refused)

AC0AF23289 628 Wed Jul 16 12:19:01
(mail transport unavailable)

AE3462545B 679 Wed Jul 16 06:55:19
(mail transport unavailable)

50C5425443 679 Wed Jul 16 01:24:04
(connect to[]:10024: Connection refused)

-- 3 Kbytes in 4 Requests.

NB: domain (my domain is not domain)

Whenever I sent emails to the created mailboxes, they do not come through. An error from my gmail account is as followS:

Technical details of temporary failure:
The recipient server did not accept our requests to connect. Learn more at
[(0) []:25: Connection dropped]
4 Answers

How are people supposed to help when you've censored every single piece of information related to your server? The only thing we can say at this point is to read the error messages, which seems to be having trouble contacting whatever is usually listening on port 10024.

What information would you like to have to be able to assist? The only thing I have removed is my domain name and IP address.

Your domain name and IP address.

Try restarting amavis. This is usually on port 10024 with ispconfig.

Have another answer? Share your knowledge.