Question

Issue with Installing HLDS on Ubantu 14 based Droplet

When I run SteamCMD.sh file it shows

./steamcmd.sh: line 29: /root/csserver/linux32/steamcmd: No such file or directory.

Following steps I have used:

Created a New folder. Downloaded and unpacked steamcmd_linux.tar.gz done tar -xvzf tried running using ./steamcmd.sh command

M using Droplet Browser Based access point.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

The following steps should be all that’s needed to get steamcmd.sh working properly. On a fresh Ubuntu system:

1.) Install dependencies

sudo apt-get install lib32gcc1

2.) Create a steam user and su to become the new user.

useradd -m steam
su - steam

3.) Create a steamcmd directory in your home directory and switch to it:

mkdir ~/steamcmd && cd ~/steamcmd

4.) Download and extract steamcmd:

curl -sqL 'https://steamcdn-a.akamaihd.net/client/installer/steamcmd_linux.tar.gz' | tar zxvf -

It should then run properly if you do a:

cd ~/steamcmd
./steamcmd.sh