Question

Issue with Let's Encrypt SSL Renewal

I have a main domain and Sub Domain in it, recently the subdomain SSL (Let’s Encrypt) got expired and I tried to renew manually. But I am getting an error like this “Challange Failed for domain app.domain.com”. Can you please help me with this issue?

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: app.domain.com Type: unauthorized Detail: Invalid response from https://app.domain.com/.well-known/acme-challenge/1ZRCzKfcZfZ3lstv6XFblgwd1pspxGy-w78U_jKvB4o [2400:6180:100:d0::40f:e001]: “<!doctype html><html lang="en"><head><meta charset="utf-8"/><link rel="icon" href="/favicon.ico"/><meta name="viewport" content=”

    To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address.

Already these records have been added.

Thank You


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @evitras

Are there any additional errors when you run the certbot renewal command:

  1. sudo certbot renew

Have you tried to temporarily disable the redirection to https and give it another go? Also, are you using any CDN like CloudFlare? You can try to temporary disable it as well.

Regards, Alex