Question

Issues connecting with FTP

I’m getting this issue when I’m trying to connect to the server…

Status: Connecting to example.com:2222… Response: fzSftp started, protocolversion=8 Command: keyfile “~.ssh\idrsa” Command: open “tanner@example.com” 2222 Error: Connection attempt interrupted by user

I used this: https://www.digitalocean.com/community/tutorials/how-to-configure-proftpd-to-use-sftp-instead-of-ftp

I made sure to open port 2222 just in case it was the firewall… anyone else getting this problem? I went through the steps a couple of times again to make sure I didn’t follow them wrong…

I went back and enabled sftp on 22 but I was still getting the same issue on that port.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@jtittle I forgot to update the thread last night. I was able to SFTP via the IP but not the domain on 22 but not 2222 – which is the port that proftpd should be on right? I just tried right now and wasn’t able to SFTP to the domain.

Slightly off topic but because apache needs permissions for the files I did a chown and unless I chown back to my username it won’t let me edit or upload files… is there a better way to deal with that?

@jtittle I was using sftp protocol for sure in both cases, 22 and 2222

@tannerchung

Generally that error means you’re trying to use the wrong protocol to connect. That guide is setting up SFTP access. If you try to connect using FTP, it will fail.

FileZilla and other clients allow you to choose which protocol you’re wanting to connect with, so you’d need to make sure it’s set to SFTP, not FTP.