Question

Issues migrating current page to DO droplet, cant create domain?

Posted August 6, 2021 94 views
WordPressCMS

Im attempting to migrate a site to my new droplet from a NamesPro server. Using CPanel I’ve always been able to create the domain on the server side and when I use a WP migration tool I simply change the DNS records. Using cPanel for my DO server, I get this error. Even now that I’ve tried changing the DNS records and nameservers with the domain registrar....

**Error:* (XID yk687h) This domain points to an IP address that does not use the DNS servers associated with this server. Transfer the domain to this server’s nameservers at the domain’s registrar or update your system to recognize the current DNS servers. To do this, use WHM’s Configure Remote Service IPs interface.*

After changing the nameservers I get this message....

**Error: *(XID chttua) The system failed to find the IPv4 address for “_____.ca.”. Because of this, the system cannot find “__.ca”’s authoritative nameservers. See the cPanel & WHM error log for more details.*

When I visit the site now it brings me to the digital ocean server (my main domain) but when I attempt to add this other domain to cPanel it won’t work. So now my site is down, and I have no way to upload the backup to my droplet. Any help would be appreciated!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @RekTek,

There is an option which allows you to add Domains which are not pointed to your Droplet in WHM. It’s called ‘Allow remote domains’.

  1. Access WHM.
  2. Navigate to Home » Server Configuration » Tweak Settings.
  3. Search for Allow remote domains.
  4. Enable this option and select Save.

While ot step 3, you can go ahead and enable - Allow creation of parked/addon domains that resolve to other servers (e.g. domain transfers) This can be a major security problem. If you must have it enabled, be sure not to allow users to park common Internet domains.

That should resolve the issue.