Issues w/ Dokku Subdomains, pushes, and DB's

May 5, 2014 2.8k views
Having some issues lately with the 1 click app Dokku on Ubuntu 14, seems to hang completely when attempting to either push or run a mysql/mariadb command. Setup Dokku using virtual hosts naming ( Can access the root domain, but all other subdomains cant be found. Have been fiddling with dns all day but no dice. Current setup is: default settings with an addition of - cname * @ As for git pushes, they initially worked, then started to error out, and now simply hang. Added them by: git remote add dokku dokku@ip_address:app_name, since dokku dokku@domain_name:app_name was giving errors. Installed mysql plugin, and running any command hangs the console, deleted mysql and install mariadb - same issue. Not sure if this makes a difference, but all the apps are php based (wordpress). Any ideas?
8 Answers
Is it possible you're running out of memory? Is there anything interesting in "/var/log/syslog" ? To look at the logs of the apps being run by Dokku, find the app's id using:

docker ps -a

and then run:

docker logs
Hey Andrew!

Running "docker ps -a" looks normal to me, but then again im not too sure what to look for, as for "docker logs" - the containers im having trouble with are saying no such file or directory..
I've resized my drop to 4gb/2cpus, 60gb ssd. 4tb transfer - but the droplet admin is showing 4GB Ram 20GB SSD Disk.. and even after the resize, the hanging still occurs..
When you say the git pushes "error out," what are the error messages you're actually seeing?

If you need to dig around in the Docker container running the app, you can get a shell with:

docker run -i -t dokku/your-apps-name:latest /bin/bash

To relaunch the app without making a git push, you can run:

docker run dokku/your-apps-name:latest
Cant remember the error outputs but im no longer even receiving errors, tried adding a new project and pushing it up and it simply hangs - no response whatsoever.

Relaunching the app returns this:

docker run dokku/schmidt:latest
PHP (classic) app detected
-----> Bundling NGINX 1.4.4
-----> Bundling PHP 5.5.9
-----> Bundling extensions
-----> Setting up default configuration
-----> Vendoring binaries into slug
mv: cannot move `/app/vendor/php' to `vendor/php/php': Directory not empty

As for the droplet resize not being what its suppose to be?
Turns out the git errors still show up if i let it hang for 30 minutes or so:

Connection to closed by remote host.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
Regarding the droplet resize, please open a support ticket:
Turns out it was a plugin, seems theres quite a few dokku plugins that cause hangups, usually a `cat` at the end of the commands file
Have another answer? Share your knowledge.