Question

Issues with SOAP and DOMDOCUMENT - Cannot get them enabled?

Hi All!

I am having trouble enabling SoapClient and Domdocument on a droplet.

Everything seems to be installed, all the modules are there, its active in php.ini but in the back end of the site that is complaining about it I still get;

Your server does not have the SoapClient class enabled - some gateway plugins which use SOAP may not work as expected.

Your server does not have the DOMDocument class enabled - HTML/Multipart emails, and also some extensions, will not work without DOMDocument.

Ive tried installing php-xml - php7.0-xml, php-dom… everything…

Tried installing as root, removed, then tried installing as a non root user with sudo, nothing.

Its ubuntu 14.4 with php7

This is the phpinfo on the server, replace the bits/spaces in the URL as appropriate etc

hXXp://www.camp bell wat son.co.uk/info.php

Really struggling with this guys!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This says that;

php5.6-xml php7.0-xml php-xml

Are already installed?

Any ideas?

https://snag.gy/RBgfUp.jpg

OK, I ran;

sudo apt-get install php7.0-soap

Which installed soap and it got ticked off the list.

Now just Domdocument

I tried;

sudo apt-get install php7.0-xml

No joy :(

Was already installed - I removed and re-added though but no joy :(

Its as if everything I need is installed but the site isnt picking it up.

So very bizarre.

The PHP soap client is packaged separately from the XML and DOM packages.

sudo apt-get update;
sudo apt-get install php-soap;
sudo service apache2 restart;

Running these will install the soap client and should resolve the error.