Question

It has been 3 days and my domain is still not active

Posted August 10, 2018 1.3k views
NginxUbuntu 18.04

I’ve done the server setup, then I did https://www.digitalocean.com/community/tutorials/how-to-install-nginx-on-ubuntu-18-04 Nginx installation like in the link, also bought a domain 3 days ago ( armvas.tech from bluehost, set the NS servers to all digitalocean ns1-3 servers,then added the domain from droplet control panel.

Is there a step I missed?

https://www.whatsmydns.net/#NS/armvas.tech - it looks like my domain hasn’t propogated in some addresses. Do I need to wait for full propogation?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @799arman

I can see that your domain is using the DigitalOcean name servers, so far so good, but it doesn’t seem like you’ve created A record pointing to your droplet’s IP address.

Go to https://cloud.digitalocean.com/networking/domains and add your domain, and create an A record for @ pointing to your droplet’s IP and then create a CNAME record for www pointing to armvas.tech

For a more detailed DNS tutorial with a few pictures:
https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean

  • Thank you! I definitely missed those steps. After the setup I was not able to access the domain without putting a www. before,but restarting nginx solved it I think. Thanks for the help

Submit an Answer