Question

It works! This is the default web page for this server. The web server software is running but no content has been added, yet.

Hello All,

I have more than one domain running properly in my server but i have a problem with this one:

http://www.caritojota.com/

when i open it in a browser shows the following message:

It works! This is the default web page for this server. The web server software is running but no content has been added, yet.

But when i open the full location it works: http://www.caritojota.com/www.caritojota.com/public_html/wordpress/

What i have been done so far is:

  1. I create caritojota.conf file and i put it within the /etc/apache2/sites-available
  2. After that using a2ensite tool i could enable the file within /etc/apache2/sites-enabled to do this part i use these commands:

a. sudo a2ensite caritojota.conf b. sudo service apache2 restart

I think the problem is in the caritojota.conf file the lines that added are:

<VirtualHost *:80> ServerAdmin webmaster@localhost ServerName caritojota.com #ServerAlias www.caritojota.com

DocumentRoot /var/www/www.caritojota.com/public_html
<Directory />
	Options FollowSymLinks
	AllowOverride All
</Directory>
<Directory /var/www/www.caritojota.com/public_html>
	Options Indexes FollowSymLinks MultiViews
	AllowOverride All
	Order allow,deny
	allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
	AllowOverride None
	Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
	Order allow,deny
	Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

I don’t know what step is missing .

Thanks in advance for your help

Subscribe
Share

Hello All,

I just wanted to let you know that i finally could fix the issue…the problem was that i had created a folder called wordpress within the root folder… and on it i had put the wordpress files. For some reason the server could not find the files, so what i did was removed everything and installed directly wordpress on the root file again and now it works properly

Maybe this advice can help you if someone will ask all of you about this problem

Regards,

Victor

also disable the default site conf

sudo a2dissite default && 

try renaming the .conf file to caritojota.com.conf

and change this line in the conf file:

 #ServerAlias www.caritojota.com

to:

 ServerAlias www.caritojota.com

and remove this bit:


<Directory />
    Options FollowSymLinks
    AllowOverride All
</Directory>

then you will want to disable the old conf and enable the new one:

sudo a2dissite  caritojota.conf  && sudo a2ensite  caritojota..com.conf 

then reload apache:

sudo service apache2 reload

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

Yes you are right i could fix it installing wordpress again directly in the root folder. It was that i did before reading your feedback.

Thank you,

Victor

Hello , I hadn’t instal before

When you installed wordpress did you set the domain to ‘http://www.caritojota.com/’ As if i go to some of the locations… like one image its trying to recieve is http://www.caritojota.com/www.caritojota.com/public_html/wordpress/wp-content/themes/david-mary/images/logo.png which doesnt exist.

Try reinstalling wordpress under your proper domain.