Question

Jitsi audio and video blocked + auth issues

Posted September 13, 2021 108 views
DigitalOcean 1-Click Apps MarketplaceUbuntu 20.04DigitalOcean Droplets

Hi all,

I ran into issues when I installed Jitsi on a droplet. I followed the documentation.

I had a well-working instance up and running approx a year ago on a recently destroyed droplet using the same documentation, but for some reason my audio and video remain blocked after the new install.

Next to having blocked audio and video, authentication I set up with Prosody is also not enforced, which is also weird as it was working fine on my old droplet.

I then decided to use the Marketplace template in case I missed something, but both issues persist, and I wonder what could be wrong.

I’m using Brave but the issues are also in Chrome.

I hope someone here knows what is wrong! It’s kinda sorta driving me insane :)

Many thanks in advance and best,
Deborah

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

I resolved this with the help of the Jitsi Community who told me to use their self-hosted guide. Your current instructions point to an old Jitsi version hence I hit all these walls. The self-hosted guide is most up-to-date documentation pointing to the latest Jitsi version. It’s probably good to update your documentation and probably as well the Marketplace Jitsi server script so it wget’s the latest version. Cheers!

Hi Deborah

I created the Jitsi image. Are you using HTTPS?
Jitsi internals changed a lot in the last years, so I had to change the image to follow changes in the APT repository.
In the end, all these changes point at better security, which is good.
Please confirm that you used Let’s Encrypt because all modern browsers shall block audio and video otherwise.

  • Hi vmvargassepulveda,

    Thanks for your response. Yes, I’m using HTTPS. I followed the self-hosted guide to a T, as well as the section on setting up the secure domain.

    The most striking difference was the sip.communicator properties that had to be used before (nano /etc/jitsi/jicofo/sip-communicator.properties), which is now replaced with a different jicofo config. Perhaps that is what differs from your image?

    I also ran into issues following the jicofo section but with this Jitsi Community solution I got the authentication to work.

    The audio / video stuff I’m not sure what was different from your image or the 20.04 documentation but something was different for sure as that’s all working fine now, too.

    I’m not super experienced yet with these things, so it might be something else, but I got it working like a charm with all aforementioned steps.

    Cheers, Deborah