Question

kali linux ssh permission denied(public key, password) problem

Hello, I tried every possible method and tutorial that exists in the internet but ssh still wants me to connect the commands with public,key and password

For example i try command ip-copy-id -i id_rsa.pub user@ip-address it will want me my password and than permission denied (public key, password)

anyone have any suggestions the others solution i tried was nano command, keygen etc…


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @akselseri,

You need to add your key in the ~/.ssh/id_rsa.pub file on your Kali installation. That’s it, there is nothing more than that.

If you are receiving permission denied (public key, password) this means your server for whatever reason can’t read the ssh key you’ve added to it. This can be due to ownership, permissions or your SSH and SSHD config which can be found in /etc/ssh/sshd_config and /etc/ssh/ssh_config.