Question

Kernal Panic - Not syncing : VFS: unable to mount root fs on unknown-block (0,0)

After rebooting the server I am getting Kernal Panic - Not syncing : VFS: unable to mount root fs on unknown-block (0,0) error, and not able to access it. Any suggestion to fix it quickly? It’s a production server having 150+ websites and all of them are down now.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey, Ill be glad to login and help you if you need me to but here’s what I did:

1- I powered off my droplet 2- Switched to recovery boot mode 3- Powered it on 4- Opened console and did the following: a- Mount file system b- chroot c- yum reinstall kernel i- I had an issue of insufficient disk space so this failed ii- I went ahead to locate my backup folder to delete one of my backups in order to make space iii- I repeated “c” above and let it run while I followed the prompt to answer a “Y” when asked… iv- I exited and x-ed out the console window d- change boot sequence back to HDD e- Powered on my droplet f- When fully powered, I opened console and did nothing while some scripts ran g- Open your site to verify - it should be up and running.

same issue when i updgraded my 16.04.4

how to solve this for ubuntu . I tried so many things : none of which is working !

i have tried :

sudo apt_get autoremove , updating initramfs .

the error i get in chroot is :

error encountered while processing these linux-image-..-

I was able to successfully get the server up and running. I got few errors while “yum reinstall kernel” but you can ignore them and wait until the command finishes processing. Lastly, exit from chroot and enter into an interactive shell and poweroff your droplet. Thanks mate,