Question

Kernel 2.6.39.4 don't work in droplet

Posted June 12, 2014 1.3k views
I need to put the 2.6.39.4 kernel in Ubuntu 12.04.4, has anyone ever achieved this feat in DigitalOcean? I just downloaded the file from the site https://www.kernel.org/pub/linux/kernel/v2.6/, compiled, but when I boot (after asking for support personnel import the kernel to droplet), fall in Ubuntu for BusyBox screen.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

2 answers
You need to ensure that your installed kernel matches the kernel set in the DigitalOcean control panel under "Settings > Kernel" http://i.imgur.com/jfvUp7Y.png The virtualization used by DigitalOcean requires that a matching kernel be found on your droplet and also set at the hypervisor level.
In compilation, I used the option "make localmodconfig", and it worked now! :)
Submit an Answer