Question

Kernel Panic Issue - not syncing VFS, unable to mount root fs

I suddenly got a notification of my CPU usage being high, and when I check my website - it was down.

And, then tried to log in to FTP to deactivate WordPress plugins to see if it’s an issue with WordPress (but couldn’t access FTP/SSH as well)

Then I went to the dashboard and tried to access the console of Digital Ocean, and it displayed the following error in the image below:

http://prntscr.com/o1z7au

The last DO support response was to go to the recovery mode then:

-check filesystem -mount disk image (or filesystem) (is it the same thing?) (Refer to this: https://www.digitalocean.com/docs/droplets/resources/recovery-iso/)

Then change the recovery mode to HDD and then power back on the droplet.

Maybe I misunderstood the official support response? Or did I miss something else?

I also tried restoring the droplet backup - that didn’t work either. Do I have to fix the issue before trying to restore the backup?

I’m kinda in a panic mode - so please help me with a detailed response. I don’t know how the hell did this problem occur in the first place.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I hope this is already sorted.

I recently had the same issue/error on a CentOS 7 server. I had more than one kernel to choose for the server and it seems like one of these available kernels was broken/not working. I’ve simply selected another kernel and the server booted properly.

Alex