Question

LAMP installation problem help me please !!

  • Posted on September 20, 2014
  • eminemAsked by eminem

https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu-14-04

in this post everything was going well but after the line :Step Three — Install PHP PHP is the component of our setup that will process code to display dynamic content. It can run scripts, connect to our MySQL databases to get information, and hand the processed content over to our web server to display.

We can once again leverage the apt system to install our components. We’re going to include some helper packages as well:

sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt

after that when i used :sudo nano /etc/apache2/mods-enabled/dir.conf it took me to a blank page but actually the page needed to contain some texts : <IfModule mod_dir.c> DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm </IfModule>

buy for mine its empty and when i entered the code in that page it say there isnt such file exist what should i do ?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

That is odd. You can also drop the DirectoryIndex directive and contents directly into your apache configuration file for the individual virtualhost by adding it inside the <VirtualHost> block in /etc/apache2/sites-enabled/default