Question

Landscape On-Premises Install issues - DigitalOcean Droplet Ubuntu 18.04

Hello all, I’m trying (and have been trying) to install Landscape On-Premises for some time on Ubuntu 18.04. As per the docs (unless I’m misunderstanding), I add the respository (ppa:landcsape/18.03), install postgresql, then install the landscape-server-quickstart package. It seems to work through most of the process just fine but ultimately fails returning:

140542236795328:error:0E06D06C:configuration file routines:NCONF_get_string:no value:../crypto/conf/conf_lib.c:275:group=req name=distinguished_name
dpkg: error processing package landscape-server-quickstart (--configure):
 installed landscape-server-quickstart package post-installation script subprocess returned error exit status 1

The ubuntu installation is fresh, I’m making no modifications other than installing postgresql and verifying that ports 80 and 443 are open. Any help would be very much appreciated.

Thanks Robert


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I had the same issue. I solved generating my own self-signed certificate and put in the directories indicated by the installer.

To generate the self-signed certificate:

openssl req -newkey rsa:2048 -new -nodes -x509 -days 3650 -keyout key.pem -out cert.pem

It will create a pem file (cert.pem) and a key file (key.pem).

Now you just need to copy them to the right place:

sudo cp key.pem /etc/ssl/private/landscape_server.key```

Then, run the installer again.


I would recommend you to use Letsencrypt (it's free!) instead of a self-signed certificate. You can easily install it and generate the certificate by following this instructions:

https://certbot.eff.org/lets-encrypt/ubuntubionic-apache

Choose the certonly option:
```sudo certbot --apache certonly```

After you generate yout certificate, create symbolic links of the pem file and the key file to the Landscape directories:
```sudo ln -s /etc/letsencrypt/live/foam.lavanderia60minutos.com.br/fullchain.pem /etc/ssl/certs/landscape_server.pem
sudo ln -s /etc/letsencrypt/live/foam.lavanderia60minutos.com.br/privkey.pem /etc/ssl/private/landscape_server.key```

This way you will not have the annoying message in the browser about yout invalid certificate.