Question

laravel spark billing portal returns an error on productionn

hi, i bought the lincense for laravel spark and i’m using it to handle subscriptions in my project (i’m using the stripe option), after integrating spark to my project, everything works well on development, i had no issues accessing the billing portal, so i deployed it on digitalocean app platflorm, composer installed everything successfully and the build was successful. i ran migrations and all my routes are working very well including nova routes, but when i tried to visit the billing portal /billing for spark, i get this error

MethodArgumentValueNotImplementedException
Symfony\Polyfill\Intl\Icu\Exception\MethodArgumentValueNotImplementedException:
The Symfony\Polyfill\Intl\Icu\NumberFormatter::setAttribute() method's argument $attribute value 0 behavior is not implemented. The available attributes are: FRACTION_DIGITS, GROUPING_USED, ROUNDING_MODE.  Please install the "intl" extension for full localization capabilities.

the error seems to be coming from one of the files in the vendor folder which i know i can’t tamper with. According to the build log, it shows

2022-01-10T20:02:18.016589091Z          - Installing symfony/polyfill-intl-icu (v1.23.0): Extracting archive

was installed successfully too but i don’t understand why this error keeps showing up, i have searched everywhere for solutions but no luck. this is my first time using laravel spark and digitalocean so i’m new to the environment

i’m using laravel 8, php8.0.1 and the new laravel spark (the one that is completely isolated from my project). i have been stuck on this for days, i don’t know what to do. please help me.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there,

It looks like that the php-intl module is not enabled.

You can enable it by adding the following to composer.json like so:

{
    "require": {
        "ext-intl": "*"
    }
}

Let me know how it goes! Best, Bobby