LEMP MYSQL default password not working

June 17, 2019 486 views

I have tried to connect to mysql using the default password provided after using the one click LEMP install and I’m just getting ERROR 1045 (28000): Access denied for user ‘root’@'localhost’ (using password: NO)

Can someone help please.

1 Answer


Looks like the server is not recognizing that you are submitting the password - are you trying to connect to via the command line?

If so, your command might look like this:

mysql -uroot -pPASSWORDHERE database_name

Notice how there is no space between the -u and -p flags and the information we are submitting, user name and password. This is my goto format for accessing mysql on the command line (although rarely as the root user once set up).

I would also mention that your mysql password and other helpful information should be displayed when you login via SSH, in the MOTD or message of the Day information. More info in this older answer, too, if you’re still stuck:


Hope this helps and good luck!

  • Hi baraboom,
    Thank you so kindly for taking the time to offer some help.
    So far I’ve tried using mysql -uroot -pPASSWORDHERE minus the database name as i haven’t been able to set anything up and still returning the same error.

    “mysql: [Warning] Using a password on the command line interface can be insecure.
    ERROR 1045 (28000): Access denied for user ‘root’@'localhost’ (using password: YES)”

    Is there a possible other method or would it be best to just f ind out how to remove mysql and reinstall?

    Edit: I’m using terminal from my laptop to ssh into the server.

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!