Hello guys,

I am trying to update certbot 0.17.0 since i have received Let’s Encrypt e-mail.

Followed another posts here but no sucess at all.

certbot: error: unrecognized arguments: update_account

Please advise.


These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

I use the method in this url https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-18-04 ,and success maybe we could have the work done by

by Hazel Virdó
by Kathleen Juell
In this tutorial, we will show you how to use Let's Encrypt to obtain a free SSL certificate and use it with Nginx on Ubuntu 18.04. We will also show you how to automatically renew your SSL certificate. If you're running a different web server, simply follow your web server's documentation to learn how to use the certificate with your setup.
  • This droplet uses Apache, not Nginx :(
    Anyway i have tried:

    root@ha:~# sudo add-apt-repository ppa:certbot/certbot
     This is the PPA for packages prepared by Debian Let's Encrypt Team and backported for Ubuntu.
    Note: Packages are only provided for currently supported Ubuntu releases.
     More info: https://launchpad.net/~certbot/+archive/ubuntu/certbot
    Press [ENTER] to continue or Ctrl-c to cancel adding it.
    gpg: keybox '/tmp/tmpwqwgfpje/pubring.gpg' created
    gpg: /tmp/tmpwqwgfpje/trustdb.gpg: trustdb created
    gpg: key 8C47BE8E75BCA694: public key "Launchpad PPA for certbot" imported
    gpg: Total number processed: 1
    gpg:               imported: 1
    root@ha:~# sudo apt install python-certbot-nginx
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package python-certbot-nginx is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package 'python-certbot-nginx' has no installation candidate

Had to upgrade to Ubuntu 18.04. Now it works.