Question

Lets Encrypt failed, Error looking up A and AAAA records.

I have been experiencing challenges using certbot to issue an ssl cert to a sub-domain mapped to one of my droplets. I have an ssl cert issued to the main domain and two other sub-domains and i had no problem doing that. However of recent when i try to issue an ssl cert to this particular sub-domain i get the following errors

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.uploads.sellingafrica.com Type: connection Detail: dns :: DNS problem: SERVFAIL looking up A for www.uploads.sellingafrica.com

    Domain: uploads.sellingafrica.com Type: connection Detail: dns :: DNS problem: SERVFAIL looking up A for uploads.sellingafrica.com

    To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address. Additionally, please check that your computer has a publicly routable IP address and that no firewalls are preventing the server from communicating with the client. If you’re using the webroot plugin, you should also verify that you are serving files from the webroot path you provided.


In the process of debugging i have tried using https://letsdebug.net/ to lookup the sub-domain and it fails to provide any record even for the main domain that already has an existing ssl cert. My question is, is it normal for https://letsdebug.net to not be able to find any record from your domain. If not what could be causing this ?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey there,

I’ve checked the records on the subdomain listed uploads.sellingafrica.com, it returns a correct A record pointing to DO: https://mxtoolbox.com/SuperTool.aspx?action=a%3Auploads.sellingafrica.com&run=toolpage

Further, I ran http & dns debug tests for that subdomain through Let’s Debug (https://letsdebug.net/uploads.sellingafrica.com/40348) and they both came back fine.

Are you still encountering the issue? It might be worth asking on the LE community forums as they might be more in-tune with handling such issues :)