Question

LetsEncrypt HTTPS error (With Laravel)

Hi,

My http works fine but if i try to run the site though the https i get this error (chrome)

This site can’t be reached MySite.co.uk refused to connect.

The following is my sites-available file:

server {
        listen 80;
        listen [::]:80;

        server_name MySite.co.uk www.MySite.co.uk;
        return 301 https://$server_name$request_uri;
}

server {
        listen 443 ssl http2;
        listen [::]:443 ssl http2;

        include snippets/ssl-MySite.co.uk.conf;
        include snippets/ssl-params.conf;

        root /var/www/html/TheStephenB/public;

        index index.php index.html index.htm index.nginx-debian.html;

        server_name MySite.co.uk www.MySite.co.uk;

        location / {
                try_files $uri $uri/ /index.php?$query_string;
        }

        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.0-fpm.sock;
        }

        location ~ /\.ht {
                deny all;
        }

        location ~ /.well-known {
                allow all;
        }
}

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

YES, sites-enabled being empty is a problem. Linking sites-available/ex.com to sites-enabled/ex.com is error prone. Use this:

sudo ln -s /etc/nginx/sites-available/yourname.com /etc/nginx/sites-enabled/

and then check that the content you read in enabled is what you read in avail.