Question

Leverage browser caching for Nginx

  • Posted on July 28, 2014
  • ganzueloAsked by ganzuelo

I am trying to speed up my Wordpress site. On GTmetrix I am receiving a E(50) for Leverage browser caching.

I am trying to add the code below to my /etc/nginx/nginx.conf file

location ~*  \.(jpg|jpeg|png|gif|ico|css|js)$ {
        expires 365d;
    }location ~*  \.(pdf)$ {
        expires 30d;
}

Unfortunately any attempt at restarting nginx ends in a [fail]

Please help!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You should add that inside of an existing server block. Usually that will be in /etc/nginx/sites-enabled/default

server {
    listen       80;
    server_name  localhost;

    location / {
        root   /usr/share/nginx/html;
        index  index.html index.htm;
    }

    location ~*  \.(jpg|jpeg|png|gif|ico|css|js)$ {
        expires 365d;
    }

    location ~*  \.(pdf)$ {
        expires 30d;
    }
}

if you have more than one website create its xyz.conf file and then add this part /etc/nginx/sites-available/xyz.conf or /etc/nginx/conf.d/xyz.conf or wherever your path is

location ~*  \.(jpg|jpeg|png|gif|ico|css|js)$ {
    expires 365d;
}

location ~*  \.(pdf)$ {
    expires 30d;
}

different .conf file will help you to reduce the confusion

try running nginx -t.