Question

Leverage browser caching on wordpress with serverpilot

  • Posted on November 9, 2014
  • batmanAsked by batman

I ran into issue when testing speed of a site. The issue is with Leverage browser caching. I setup my server has a 1GB Ram 30GB SSD Disk New York 3 Ubuntu 14.04 x64 and using server pilot. The site seems to run great except for this issue. Any suggestion on how to resolve the leverage issues?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Presumably, you are referring to the Leverage Browser Caching rule from Google’s PageSpeed Insights.

If your site is using Apache, one way to allow browsers to cache your content is by setting Expires headers on your static files. First run sudo a2enmod expires Then add the following to your VirtualHost or .htacccess file:

<IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/jpg "access 1 year"
    ExpiresByType image/jpeg "access 1 year"
    ExpiresByType image/gif "access 1 year"
    ExpiresByType image/png "access 1 year"
    ExpiresByType text/css "access 1 month"
    ExpiresByType application/pdf "access 1 month"
    ExpiresByType text/x-javascript "access 1 month"
    ExpiresByType application/x-shockwave-flash "access 1 month"
    ExpiresByType image/x-icon "access 1 year"
    ExpiresDefault "access 2 days"
</IfModule>

Finally, restart Apache with sudo service apache2 restart Your site will no longer display that warning in Google’s PageSpeed Insights.

I’m busy with same stuff right now… Serverpilot installs a custom apache version and common apache tools doesn’t work.

I got this snippet from a friend and the headers are looking fine, but I’m still getting these warning from Google insights :(

<IfModule mod_deflate.c>
SetOutputFilter DEFLATE
</IfModule>

<IfModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 year"
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/png "access plus 1 month"
ExpiresByType image/jpg "access plus 1 month"
ExpiresByType image/jpeg "access plus 1 month"
ExpiresByType text/css "access 1 month"
ExpiresByType application/javascript "access plus 1 year"
</IfModule>