Question

LiteSpeed Wordpress droplet Loggin

Posted September 15, 2021 126 views
WordPressLogging

I have a litespeed wordpress droplet configured. I was reviewing the logs and noticed my activity was not showing. It seems not all activity is logged, I went on another computer and browsed the site and nothing is logged as I monitored via tail -f /usr/local/lsws/logs/access.log

I want to closely monitor and export these logs to a SIEM but I am not getting all the data I expect.

My httpd_config.conf is set to:

accessLog logs/access.log {
        rollingSize          40M
        keepDays             120
        compressArchive      1
        logReferer           1
        logUserAgent         1
}

Example of my log file showing the todays recent events but not mine:

172.94.00.000 - - [15/Sep/2021:14:19:00 +0000] "GET /nice%20ports%2C/Tri%6Eity.txt%2ebak HTTP/1.0" 404 1236 "-" "-"
172.94.00.000 - - [15/Sep/2021:14:19:00 +0000] "GET / HTTP/1.0" 404 1236 "-" "-"
172.94.00.000 - - [15/Sep/2021:14:19:01 +0000] "OPTIONS / HTTP/1.0" 404 1236 "-" "-"
172.94.00.000 - - [15/Sep/2021:14:19:02 +0000] "GET /nice%20ports%2C/Tri%6Eity.txt%2ebak HTTP/1.0" 404 1236 "-" "-"
172.94.00.000 - - [15/Sep/2021:14:20:47 +0000] "POST /IPHTTPS HTTP/1.1" 404 1236 "-" "-"

What am I missing? Can I get more verbose logs?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Solved, had to expose the lightspeed portal and configure logging for the virtual host.

Hi @tjenkins,

I see you’ve fixed the issue you’ve had. Can I ask you to provide the quick steps you did and where exactly you changed the configuration? I’m asking for the possibility of another person finding the question.