Question

Load Balancer not running when setting up Nginx Ingress on Kubernetes

Hello,

I am following the tutorial on this page

I ran the command to set up v1.1.1 of the Kubernetes-maintained Nginx Ingress Controller:

kubectl apply -f https://raw.githubusercontent.com/kubernetes/ingress-nginx/controller-v1.1.1/deploy/static/provider/do/deploy.yaml

PROBLEM: A load balancer does indeed get provisioned however the traffic status remains as 0/1 always (with a red downwards arrow in UI)

Furthermore, when I run the command to apply to ingress yaml file: kubectl apply -f echo_ingress.yaml

I get the following output from my command line:

Error from server (InternalError): error when creating "echo_ingress.yaml": Internal error occurred: failed calling webhook "validate.nginx.ingress.kubernetes.io": failed to call webhook: Post "https://ingress-nginx-controller-admission.ingress-nginx.svc:443/networking/v1/ingresses?timeout=29s": EOF

Any indications as to why this is happening would be a great help.

Thank you very much in advance, Ali


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer