Question

Load-balancer related issue / question

I have a python flast app running on port :5005 on 2 servers (with nginx installed). I am trying to setup a load balancer with round-robin approach but it ends up going to “503 bad request, no servers were available”.

If I visit xx.xx.xx.xx:5005 of each server individually, I could see the app. I have redirected port 80 and 443 of load-balancer to 5005 of the droplet.

Any help would be appreciated.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Was this ever resolved? I have the same issue.

I have the same issue and an open ticket, #2483180. Load balancer was working until recently and now I can’t make it behave

Hey friend!

Interesting issue. Hopefully I can offer some insight. What is the HTTP code returned by your application on request? It is possible that the code returned is something the LB determines to mean that the request could not be returned, as opposed to like a 200 code.

Jarland