Question

Load Balancer says droplet down but it is up

Hi

My load balancer shows the status of one droplet as down and the other is up. However, both droplets can be accessed individually. Can anyone help with this?

Subscribe
Share

I think digital ocean checks main ip address of droplet. In my case i just make enabled “default” nginx config, so when you open ip address directly it yells “Welcome to nginx!”. And after 2 minutes load balancer said droplet is Healty.

I think you could just put empty page, but i leave it like it is.

I have the same issue, suddenly load balancer shows my droplet is down, but when I checked manually to my droplet, it is fine, the web server is up… after some moment the load balancer said droplet is healty again, back to online, i don’t know why this is happening

I am having the same issue. How did you resolve yours?

Yeah experiencing the same issue. Droplets are individually accessible and healthy but show up as down on the load balancer.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

same here. @uusa35fc8632c17142324fe9ff did you get any information?

same here

i just made support ticket it’s strange.

I am experiencing the exact same issue. I can access any droplet on the load balancer directly and it resolves fine, but the Load Balancer itself says that the droplet is down.

I know that the status is determined from health checks, but the health check settings are pointed directly at port 80 on those droplets - so I’m just not really sure what else to do.

Hello,

You might want to double check that there is nothing blocking the health checks and pings that are being done from your Load Balancer to your respective droplets.

In my case it was fail2ban which had picked up the Load Balancer’s local IP address.

tail -f /var/log/fail2ban.log 

To ensure this doesn’t continue happening you might want to add your VPC’s ip block to the fail2ban igonore list. Adding only the load balancers IP might not work as it might be subject to change.

To do so simply execute the following commands:

  1. Copy fail2bans jail.conf and change it
cp /etc/fail2ban/jail.conf /etc/fail2ban/jail.local
  1. Look for the ignoreip line, uncomment it, add your VPC block and save it.

You can find your VPC’s ip range in your Digital Ocean account under Networking > VPC

nano /etc/fail2ban/jail.local

Hoping this saves you some time!