Question

Load Balancer Slow in Forward Request

Posted July 20, 2017 3k views
UbuntuFirewallLoad Balancing

i have a domain.com point to digital ocean loadbalancer ip to distribute to 2server. when i try to use access the web via domain.com it is extremely slow and sometimes even timeout. but when i try via my server hostname it is working normally, what possible cause to this? is the load balancer slow in forwarding request?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
7 answers

looks like problem solved by changing do load balancer setting and update it. maybe this make loadbalancer to restart and update.

Same issue, and sure enough changing a setting resolved it. Ugh.

having same issue, would mind to share setting to resolved the issue?

Same issue here… the workaround mentioned above about changing the setting fixes it immediately, but it returns back to broken after about 30 seconds.

@sarahjk – I just changed Algorithm and then put it back.

Its an old case of mine, because i don’t get any solution, so i build own loadbalancer using DO droplet and floating ip.
Looks like the haproxy setting is not suitable. On my case, i guess that my user has over the limit of max connection. So it cause the new connection is in queue and not serve directly. And because i can’t change that setting so i build myself own loadbalancer and increase max connection setting from the default one.
Hope this help.

I have the exact same problem with a LoadBalancer I created through kubernetes. Port 80 http traffic is fast but port 443 ssl traffic is extremely slow. When I flip a setting like algorithm it becomes fast on ssl but then after a while reverts back to being slow.

  • Looks like I have the same issue.

    80 http traffic is always fast. But according to webpagetest.org SSL Negotiation takes about 30 seconds. But when I click SAVE in Proxy Protocol on Load Balancer Setting page, SSL Negotiation becomes fast — 128 ms! But after a while it backs to being slow. Clicking on SAVE makes it go faster again for some time.

    Is it a bug?

    • In my case I eventually realised that the IP provisioned for my loadbalacer was a victim of an ongoing ddos attack. I reprovisioned to get a new IP and after that it worked.

      • Wow. How did you get that info about your IP?

        • I setup a nginx ingress in my k8s cluster and saw the nginx log being spammed with a lot of strange HTTPS requests. Basically they were sending HTTPS requests but with binary garbage so at first I did not understand what it was. All requests origninated from the same 2-3 countries.

Yeah, i experienced this too. It’s caused by algorithm setting, it’s slow when i chose “Least Connection”. But when i revert back to “Round Robin” all go back to normal. What’s goin on here, i don’t know too

Submit an Answer