prraney
By:
prraney

Login to zpanel gives Invalid Token problem!

July 25, 2013 7.6k views
When I type in my ip address, I get this error -> 'Application Error: [0204] - The form you attempted to submit had an invalid token' When I try to connect to the database i get this error -> 'Could not connect: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' I searched online a lot about the first problem, they said add this line "" in a file called 'login.ztml'. BUT, I went into that file, it's already been added inside the tags! HELP required!!
1 comment
  • Hello Guys

    Did anyone manage to resolve this issue as its been a few weeks i got the same error message.

    We would really appreciate it if someone can help us on this matter

    thank you for your time

    Regards

    Fazz

10 Answers
EDIT: I searched online a lot about the first problem, they said add this line "< ? php echo runtime_csfr::Token(); ? >" in a file called 'login.ztml'.
What steps did you take to install MySQL?
Through putty...some mysql installing commands...! I checked 'em out from google! What could be the problem according to you?
Did you install MySQL yourself or did zPanel install it for you?
hai zamal nasser

i installed it manually please help me buddy

via hackla4440@gmail.com

Hello Guys

Did anyone manage to resolve this issue as its been a few weeks i got the same error message.

We would really appreciate it if someone can help us on this matter

thank you for your time

Regards

Fazz

You surely have a session permission problem. If you check your /var/log/httpd/error_log you will see that you have an error 13 in the permissions of your zpanel directory.

This is a permission error and I got it long time ago by using mpm-itk in httpd. I had asterisk on the same box and wanted to add zpanel as well to get some domains up. I used itk to have asterisk run under the user "asterisk", while the vhosts run under the "apache".

When you use an additional package which changes the user running your sessions, you get issues like that. My solution was to use mpm-itk and have the zpanel vhost run under root, while asterisk and its web platform were run by user "asterisk" and the other vhosts created by zpanel run by user "apache".

Antonis

So I am getting this issue as well. Anyone know of how to fix this?

Make a free space on disk.

Have another answer? Share your knowledge.