Question

Magento Database Error - Magento Doesn't Install

  • Posted on November 11, 2014
  • BorisAsked by Boris

Hi,

I need to install magento. I followed this instruction: https://www.digitalocean.com/community/tutorials/how-to-use-the-magento-one-click-install-image

After magento was installed with one click (droplet was created) - i tried to login to magento - it went me through installation process, but the gave we an database error.

I realized that magento needs a database, so I followed tutorial for LAMP. After I did so - i tried to login and continue with magento installation again - but got the same database error, so I continued this tutorial: https://www.digitalocean.com/community/tutorials/how-to-use-the-magento-one-click-install-image,.

The last thing I did is: "Find the lines containing the information for the existing self-signed cert:

    SSLEngine on
    SSLCertificateFile /etc/apache2/ssl/apache.crt
    SSLCertificateKeyFile /etc/apache2/ssl/apache.key

and replace the the paths with the location of the files obtained from your certificate authority.

    SSLEngine on
    SSLCertificateFile /etc/apache2/ssl/ssl.crt
    SSLCertificateKeyFile /etc/apache2/ssl/private.key
    SSLCertificateChainFile /etc/apache2/ssl/sub.class1.server.ca.pem"

Then tutorial says enter this command to reboot apache: sudo service apache2 restart

but when i typed this line into my terminal I got an error message: root@YBF:~# sudo service apache2 restart

  • Restarting web server apache2 [fail]
  • The apache2 configtest failed. Output of config test was: apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Syntax error on line 19 of /etc/apache2/sites-enabled/magento-ssl.conf: Expected </VirtualHost> but saw </FilesMatch> Action ‘configtest’ failed. The Apache error log may have more information. root@YBF:~# nano /etc/apache2/sites-available/magento-ssl.conf

What I am doing wrong? How do I fix it?

Thans

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Did you find the answer to this?

I had the same problem but put it down to having an SSL Certificate with a Private Key that didn’t match.

<IfModule mod_ssl.c> <VirtualHost default:443> #ServerName www.example.com DocumentRoot /var/www/html/magento

	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined

	<Directory /var/www/html/magento>
		AllowOverride All
		Require all granted
	</Directory>

    SSLEngine on
    SSLCertificateFile /etc/apache2/ssl/ssl.crt
    SSLCertificateKeyFile /etc/apache2/ssl/private.key
    SSLCertificateChainFile /etc/apache2/ssl/sub.class1.server.ca.pem	<FilesMatch "\.(cgi|shtml|phtml|php)$">

	 			SSLOptions +StdEnvVars
	</FilesMatch>
	<Directory /usr/lib/cgi-bin>
	                SSLOptions +StdEnvVars
	</Directory>
	BrowserMatch "MSIE [2-6]" \
				nokeepalive ssl-unclean-shutdown \
				downgrade-1.0 force-response-1.0
	BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown
	</VirtualHost>

</IfModule>