Question

Magento Problems - CMS can't access file, while FileZilla can

Posted November 19, 2014 5.5k views

Hi,

I was trying to change my slider image on my magento via its admin panel, but when i tried to upload new image it gave me this error message: “The directory /var/www/html/magento/media/wysiwyg/blanco is not writable by server.”

The thing is - I can upload it via filezilla and insert URL, but for some reason I can’t do so via Magento admin panel - why?

Maybe i need to change somewhere access/permission? If so - how?

Thanks

1 comment
    1. Regarding the error “The directory /var/www/html/magento/media/wysiwyg/blanco is not writable by server.”:
    2. Check if that folder exists and whether it has write permissions – 777.
      2 The solution is to change just one setting in admin:
      System -> Configuration -> General -> Content Management -> Use Static URLs for Media Content in WYSIWYG for Catalog to Yes
      Dont forget to clear the caches when you are done!

    3. The Flash Upload doesn’t handle invalid or self-signed certificates. It just throws an error, therefore you have two possibilities:

      • Create a certificate and make sure it is trusted in your system.
      • Just remove the https from the url and use http on your local dev system (the url can be changed in the backend: System > Config > Web > (Un)secure Baseurl
      • You could also try using a different browser, e.g. Internet Explorer.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Is also gives me this error when I try to upload via admin:
1) SSL Error: Invalid or self-signed certificate
2) Upload I/O Error

  1. Regarding the error “The directory /var/www/html/magento/media/wysiwyg/blanco is not writable by server.”:
  2. Check if that folder exists and whether it has write permissions – 777.
    2 The solution is to change just one setting in admin:
    System -> Configuration -> General -> Content Management -> Use Static URLs for Media Content in WYSIWYG for Catalog to Yes
    Dont forget to clear the caches when you are done!

  3. The Flash Upload doesn’t handle invalid or self-signed certificates. It just throws an error, therefore you have two possibilities:

    • Create a certificate and make sure it is trusted in your system.
    • Just remove the https from the url and use http on your local dev system (the url can be changed in the backend: System > Config > Web > (Un)secure Baseurl
    • You could also try using a different browser, e.g. Internet Explorer.
Submit an Answer