Question

Mail server not working

Hi, I’m unable to configure mail server on my ubuntu box.

First I tried iRedmail, which I’m familiar with and I had no problem setting up in the past but this time I was unable to send the email (I was able to receive the mail just fine).

Now I’m using “Mail in a box” and still not able to send the mail.

I followed this tutorial to install “Mail in a box”.

I followed every step but it’s saying 25 port is blocked by the network but I checked on my server, the port is open

Screenshots https://ibb.co/dh4wfv https://ibb.co/kj807a

Note- The only thing I didn’t follow from the tutorial is that, my droplet name is not same as my hostname. (Droplet name- inprinters.co.uk, Hostname- box.inprinters.co.uk)


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @inkable

When you try to send a mail, what happens? The screenshot you’ve supplied is only a small check if the server can connect to Google’s SMTP server.

So let’s have a look at the Postfix log - run this command to show the last 30 lines:

tail -30 /var/log/mail.log