I installed MySQL on 3306 port. Change bind_address property of /etc/mysql/my.cnf file to 0.0.0.0. Then reload server. But still can`t access from Toad client.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Most likely ufw, but you shouldn’t do this. MySQL sends data and passwords plaintext. Use a SSH tunnel.

Its True that MYSQL sends data in plain text format, but with that said do the following to check if your server is reachable

  • Ping the Server from the client node
  • use NMAP or telnet to see if you can telnet to port 3306 [Windows Use : Dtelnet, Linux Already has telnet]
  • Also see if you have firewall enabled on the server.
Submit an Answer