Question

Managed Database can't create a table for Vimeography Pro - Wordpress plugin

Posted February 10, 2020 161 views
MySQLWordPressDigitalOceanDatabases

Note: I have 3 sites running on managed DO databases and all are doing fine except for this issue.

I have reviewed the WordPress error log and engaged the author of the Vimeography Pro plugin and after reviewing the site as an Admin here what he concluded:


This is a simple WordPress database insert that really would only fail if the table doesn’t exist or you’ve otherwise made some modifications to the $wpdb global.

I would recommend your developer look closely at the database structure to be sure there is a table called wp_vimeography_pro_meta with the correct structure.

  public static function create_vimeography_pro_gallery($id) {
    global $wpdb;

    $row = $wpdb->insert(
      $wpdb->vimeography_pro_meta,
      array(
        'gallery_id' => $id,
        'per_page'   => 20,
        'sort'       => 'default',
        'direction'  => 'desc',
        'playlist'   => 0,
        'allow_downloads' => 0,
        'enable_search' => 0,
        'enable_tags' => 0
      ),
      array('%d', '%d', '%s', '%s', '%d', '%d', '%d', '%d')
    );

    if ( ! $row ) {
      throw new Vimegraphy_Exception( __('Your Vimeography Pro gallery settings could not be saved.') );
    }

    return TRUE;
  }
"

It all started with the following persistent Wordpress error:

An error of type E_ERROR was caused in line 38 of the file /var/www/html/wp-content/plugins/vimeography-pro/lib/admin/view/gallery/new.php. Error message: Uncaught Error: Class 'Vimegraphy_Exception' not found in /var/www/html/wp-content/plugins/vimeography-pro/lib/admin/view/gallery/new.php:38
Stack trace:
#0 /var/www/html/wp-includes/class-wp-hook.php(288): Vimeography_Pro_Gallery_New->create_vimeography_pro_gallery(10)
#1 /var/www/html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters('', Array)
#2 /var/www/html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
#3 /var/www/html/wp-content/plugins/vimeography/lib/admin/controllers/gallery/new.php(48): do_action('vimeography-pro...', 10)
#4 /var/www/html/wp-content/plugins/vimeography-pro/lib/admin/view/gallery/new.php(12): Vimeography_Gallery_New->__construct()
#5 /var/www/html/wp-content/plugins/vimeography/lib/admin/menu.php(112): Vimeography_Pro_Gallery_New->__construct()
#6 /var/www/html/wp-includes/class-wp-hook.php(288): Vimeography_Admin_Menu->load_new_gallery_page('')
#7 /var/www/html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters('', Array)
#8 /var/www/html/wp-includes/plugi

I’ve tried the following in the global SQL mode in the Settings page of the Database Cluster Digitalocean cluster but it hasn’t helped:
1) Traditional
2) ANSI, NOZEROINDATE, NOZERODATE, ERRORFORDIVISIONBYZERO,NOENGINE_SUBSTITUTION

Thanks
James

edited by bobbyiliev

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

This is quite interesting, it sounds like that the table does not exist. Try the following:

  • Disable the plugin
  • Enable Wordpress debug mode
  • Enable the plugin again
  • Check your error logs
  • Connect to your database with an SQL client like DBever or any other and check if the wp_vimeography_pro_meta table exists
  • If there are any updates for that plugin, install them and try again

Hi ServerEnthusiast,
Thank you for your detailed suggestions. The author of the plugin Dave Kiss, was provided unfettered admin access to the server and he tried reinstalling and debugging as you suggest with all other distractions (plugins, themes) ruled out. I’m on:

  • WordPress 5.3.2
  • Vimeography Pro 2.02
  • PHP 7.2.24-0ubuntu0.18.04.2, MySQL 8.0.16

the latest Wordpress version and this combination works fine elsewhere and here are some results for an older WP version from plugintests.com

https://plugintests.com/plugins/vimeography/2.0.2

I want to avoid engaging the plugin author on the DO managed cluster if this can be resolved with help from the community and hope to learn the best practices when debugging issues involving a managed WP DB.

I will try to pursue your suggestions on my own and update.

Thanks
James

Submit an Answer