I’ve setup a Redis cluster trough DigitalOcean Managed Databases. It’s up and running. I have a WordPress website which I’d like to connect to the cluster.

I’ve installed “Redis Object Cache” ( https://wordpress.org/plugins/redis-cache/ )

I’ve setup the following defines in my wp-config.php:

define( 'WP_REDIS_HOST', 'my-private-do-hostname');
define( 'WP_REDIS_PORT', '25061');
define( 'WP_REDIS_PASSWORD', 'my-password');
define( 'WP_REDIS_SCHEME', 'tls');

I’ve added my droplet to be a allowed on the private network. But the plugin keeps saying:

Status: Not Connected
Client: PhpRedis (v3.0.0)

So it stays unconnected.

Anyone got this up and running using WordPress?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hi @NielsV,

Make sure you can actually connect for the droplet to the Redis cluster. I’ll assume it’s not the Wordpress fault as more to the connection between the two servers.

I’ll recommend you to try and open the REDIS port on both servers,both IN and OUT connections, add rules to IPTABLES to allow traffic from the droplets.

You can try to connect with telnet and the specific port, another option would be traceroute to the Redis’s server IP address.

Kind regards,
Kalin

Hi guys,
i’ve the same problem

when i try to connect from terminal it’s all ok

when use wp i’ve this message
connection timeout...

someone have a wp instance with redis?

thanks

Havinf exact the same issue!

Using centos with firewalld disabled. Redis Object Cache diasgnostics:

Status: Not Connected
Client: PhpRedis (v4.3.0)
Drop-in: Valid
Connection Exception: phpnetworkgetaddresses: getaddrinfo failed: Name or service not known (RedisException)
Redis Extension: 4.3.0
Predis Client: 1.1.1
PHP Version: 7.3.13

When i am connectiong through redis-cli it seems that i can connect without any error. When i send a command “ping” i am getting error: Error: Server closed the connection

Submit an Answer