Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

By jhoffjann
I have Jetty Server I built with Maven and Java 8 in my Ubuntu Droplet. I was able to start it once just fine and could communicate with it over port 8080.
Since I wanted to run it in a different screen I stopped, opened screen and tried to restart it with mvn jetty:run -Dplatform.dependencies since then it doesn’t start anymore, but I don’t get a error message either.
[INFO] Context path = /opencvserver-server
[INFO] Tmp directory = determined at runtime
[INFO] Web defaults = org/mortbay/jetty/webapp/webdefault.xml
[INFO] Web overrides = none
[INFO] Webapp directory = /root/OCV_Server/opencvserver-server/src/main/webapp
[INFO] Starting jetty 6.1.10 ...
2014-11-17 17:41:22.124::INFO: jetty-6.1.10
2014-11-17 17:41:22.484::INFO: No Transaction manager found - if your webapp requires one, please configure one.
When I start it locally it looks like this:
[INFO] Starting jetty 6.1.10 ...
[INFO] jetty-6.1.10
[INFO] No Transaction manager found - if your webapp requires one, please configure one.
[INFO] Initializing Spring FrameworkServlet 'rest-app'
[INFO] Started SelectChannelConnector@0.0.0.0:8080
[INFO] Started Jetty Server
So it seems to fail when initializing the Servlet.
I know this is a really specific question but is there a way to find out what is going wrong with maven in the droplet? Filter for some error message that aren’t shown to me? On my local machine (OS X Yosemite) it runs just fine and I’m not too good with Ubuntu.
This is my maven config:
mvn -v
Apache Maven 2.2.1 (rdebian-14)
Java version: 1.8.0_25
Java home: /usr/lib/jvm/java-8-oracle/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux" version: "3.13.0-37-generic" arch: "amd64" Family: "unix"
Any help would be appreciated.