Question

Max upload file wordpress only 2mb

I want to increase my upload file space… because if i upload more than 2mb, showed alert that ‘maximal upload from hosting provider only 2mb’. in here, my hosting provider is digitatl ocean


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

What you can do is to create an info.php file and then check the values. You can create a file named info.php (the name doesn’t really matter) and put the following content in the file:

<?php
phpinfo();

Then check for the current value of upload_max_filesize and post_max_size you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 64M
post_max_size = 64M

Hope this helps! Regards, Alex

Hi there @infofreelenstudio,

You would need to increase the PHP post_max_size and upload_max_filesize via your php.ini file.

I could suggest following the steps from this tutorial here on how to adjust your PHP settings:

https://www.digitalocean.com/community/tutorials/how-to-change-your-php-settings-on-ubuntu-14-04

Regards, Bobby