Hi!
i want to change different values in php.ini for my wordpress website, I want to change max input vars to 4000, I removed default semicolon and also I change other values in php.ini, other values change apply after restarting mysql but max input vars not changing.

Any solution?
Thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Me ocurre exactamente lo mismo y tengo servidor Centos 7, en otros servidores no tengo este problema solo en lo que tengo alojado con DO

Encontré la solución,

Para verificar los cambios estaba usando phpinfo();
pero no importa lo que hiciera se mantenía igual.

Lo que no sabía es que al inicio del reporte aparece un valor “Loaded Configuration File ” este te dice desde donde está cargando las opciones de PHP, es decir donde esta ubicado el php.ini de configuración actual, lo que hice fue buscar este archivo en el servidor, lo edité y reinicié el servidor y ahora funciona perfecto.

Recomendación: deshaz todos los cambios que hiciste antes para dejar todo como estaba.

Suerte.

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of maxinputvars you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

max_input_vars = YOURVALUE

Note: Change YOURVALUE with the value you want to set, e.g 3000

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex

Submit an Answer