Question

Maximum upload size

Posted March 3, 2018 10.9k views
ApacheUbuntu 16.04

I can’t upload files over 1MB. I’ve checked in php.ini and the settings there say maximum upload size is 16 MB. So there appears to be something else limiting upload size. Please advise as the 1 MB limit makes the droplet unusable for my intended use.

1 comment
  • I’ve now added one file to the media library - size 537 KB. But I can’t add another as maximum upload is now 0B!!! Is there a setting somewhere to allocate more space to the media library?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Can you provide a bit more information. Unfortunately what you’ve shared is not enough to determine what’s occurring.

1.) How are you uploading files? SFTP? A web app?
2.) If this is a website are you using a platform like WordPress? Is it a PHP site? A Rails site?

Since WordPress on LAMP (Linux Apache MySQL PHP) is the most common stack I’ll address that here:

PHP has some fairly small default max filesize settings for uploads. This can be changed by editing your php.ini file. On Ubuntu this file can be found in /etc/php7-0/php.ini

In this file there are two directives you will want to change to increase the upload size:

maxpostsize - This tells php what the largest request it will accept as a POST. This is the method used when uploading files so it will need to be set larger than the largest file you plan to upload.

uploadmaxfilesize - This is more specific and refers to the maximum size for any file that is uploaded using php.

Once these two settings are changed you will need to restart Apache service apache2 restart for the changes to take effect.

  • I’m using a pre-configured Wordpress droplet, and I’ve already increased the allowable download size in php.ini from 16 MB to 24 MB, but that has had no effect. I’m trying to upload files using the Wordpress uploader. I have found a way round the problem using the plugin “Upload Max Filesize” but I would like to know what setting is needed to achieve this without a plugin.

I am also changed the size but when i am trying to upload my sql backup files to mysql then it shows only 2mb files are allowed to upload.. there is no any clear instructions on digital ocean about changing the file size.. still waiting for ticket from last 2 days

Hello,

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 64M

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex

Submit an Answer