Mezzanine deployment - .virtualenv missing Mezzanine after running fab install/create/deploy/all

Hey all! Have gotten past some previous issues, and managed to upload the project through Git. Now when I want to testrun the server using gunicorn, like cd into the project folder and run python runserver as usual, I get the error:

File “”, line 7, in <module> from mezzanine.utils.conf import real_project_name ModuleNotFoundError: No module named ‘mezzanine’

So it’s my understanding when i run fab all, or the individual sequences like fab install and create, that it should automatically create a venv with packages according to the requirements.txt

The requirements.txt is up to date, and has mezzanine listed in it.

I’m running on windows 7, but doubt that has any meaning at this point when the resources are pushed onto the droplet, and I can clearly see through FTP that Python is installed in the .virtualenvs folder, but none of the other necessary resources.

I tried running “pip install mezzanine” while having the virtual env activated through SSH, but can’t see where it installed it, definitely not the virtualenv’s lib folder.

How can I properly get all the necessary packages (mezzanine) up to the droplet? Thanks for reading.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I got it working, and mezzanine with all dependencies got installed. It seems it is an empty mezzanine project install however, as now it asks me to fill in a lot of settings which I added to local_settings locally.