Migrating database to DigitalOcean using BackupBuddy

January 26, 2014 2.3k views
I am in the process of migrating my WordPress site from shared hosting to DigitalOcean. I set up a fresh install of WordPress using one-click installation, and I replaced the standard wp-content folder with my original folder. I am trying to migrate my database over using BackupBuddy, but I am getting an error when I try to access the importbuddy.php file. This is the error that I am getting: Error #224834. This directory is not write enabled. Please verify write permissions to continue. Any ideas? I'm sure I am just overlooking something simple. Thanks!
1 Answer
Looks like you have a permissions problem. What's listed as the owner:group of your WordPress directory? To find out, execute:
ls -l /path/to/WordPress/Installation

To learn more about permissions, check out Linux Permissions Basics and How to Use Umask on a VPS.
by Justin Ellingwood
In this article, we will discuss how to read and manipulate Linux permissions. We will cover how to use the "umask" command to choose default permission settings, and the "chmod" command, which can change the permissions of files and directories.
Have another answer? Share your knowledge.